Results 1 to 9 of 9

Thread: Steering stiff

  1. #1
    Join Date
    May 2007
    Posts
    1,183

    Default Steering stiff

    Appleton rack, sweet pump (Toyota design more pressure), stock frame and spindles, swedge tube and heims. This system steered like dream last year but this year been nightmare. Had rack go bad, thought was pump but finally got right. Now last month steering getting tighter and tighter when go thru corner and car weight on rf. Have new pump, rack rebuilt by Appleton, new lines from pump to rack. Slow speed it steers one finger, even swerving like trying to heat tires but soon as green drops it's like no power steering thru corners. We're lost. Can't find anything binding, went thru lf since has had contact. Going thru rf tonight. 2 weeks ago steering mid race freed up like nothing wrong for 5 laps or so then back to crap. Any ideas?

    I'm thinking about re-doing rack set-up over winter to improve overall. When choosing length should I use center to center of lower control arms or is there something different to designing front? Currently using 18¼ cause what we had when built.
    Thanks guy's, i came cause running rack like late models

  2. #2
    Join Date
    Nov 2014
    Posts
    437

    Default

    Put kse power steering fluid in. I had the same issue. And was running off the shelf valvoline fluid. Swapped to kse fluid, or whatever fluid your pump manufacturer recommends. Made it completely different.

  3. #3
    Join Date
    May 2007
    Posts
    1,183

    Default

    Running kse already. Appreciate thought, I should of added we redid steering to eliminate couple things and that didn't help.

  4. #4
    Join Date
    May 2007
    Location
    Batavia, OH
    Posts
    12,079

    Default

    It sounds like your pump is not being supplied with proper volume on the suction side. Pump speeds up, but can't pull an adequate volume.

    Line collapsing? Not enough volume in tank?
    Droop isn't the problem.

    Arizona Speedway - 2 ........ Brushcreek -1
    Alltech -1 .................... Eldora - 8
    East Bay - 6 .................. Richmond -1
    Florence -1 ................. Lawrenceburg -1
    Atomic -6 .................. Circle City -1
    Tazewell -1 .................. Mudlick-1
    Moler -4
    Portsmouth -3 .....................Tyler Co. -1

  5. #5
    Join Date
    May 2007
    Posts
    1,183

    Default

    Changed lines last night and full reservoir. Found rf ball joint bad which shocked cause only maybe 30 shows total. We Changed to spare rack We went thru and think that got it cause ball joint didn't. Best could tell was power assist was moving slightly when turn side to side. Appreciate help and y'all. If that fixes then certainly wasn't what was expecting on recent manu rebuild

  6. #6

    Default

    May sound crazy , but I had the -10 reservoir line, not rated for vacuum, suck closed at speed. Some of the braided lines are not rated for suction!
    Last edited by Len72P; 10-02-2021 at 07:04 AM.

  7. #7

    Default Suction lines

    I put a line spring in all suction lines

  8. #8
    Join Date
    Jan 2012
    Posts
    293

    Default

    I had a similar issue when I put a KSE pump on a car that had a non-baffled tank. You could rev the motor and the fluid would “vortex” so bad that you could see the feed line in the tank.

    Replaced with a kse tank and problem solved, except for I ran it too long with the tank that way and starved the pump and ran it “dry” long enough that it damaged the rotary piston and couldn’t pump fluid anymore. Had to send it off and pay $500 for a rebuild. Problem was solved for good after that

  9. #9
    Join Date
    Jul 2009
    Posts
    1,287

    Default

    if it bolts on the back of the oil pump, check the hex on the oil pump and steering and fuel pump, i change that every year now, cost us a race or two, idling would be fine, hit the fuel no power steering, it stripped out the deal in the oil pump on us

    sorry, ill read entire post next time, lol, but its an issue on the late models so if reading check this too
    Last edited by grt74; 10-11-2021 at 09:15 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

All times are GMT -5. The time now is 11:32 AM.


Powered by vBulletin® Version 4.2.0
Copyright © 2021 vBulletin Solutions, Inc. All rights reserved.